Mattermost call plugin remote is not working


I recently installed mattermost for my company, we can connect to the server from anywhere but we have a problem when trying to make calls.

Calls are only working when the two users are on the same network, on the company’s site.

When trying to call from remote connection, without VPN, it is not working, only the one being on company’s site can enter the call.

Mattermost is installed on a linux server with an nginx proxy

The company also has a nginx reverseproxy (that is not involved for on site’s communication).

When trying to call, here are the errors logs on mattermost server :

{“timestamp”:“2023-10-09 16:00:21.877 +02:00”,“level”:“error”,“msg”:“failed to read RTCP packet”,“ca ller”:“app/plugin_api.go:976”,“plugin_id”:“com.mattermost.calls”,“origin”:“main.(*logger).Error log. go:103”,“error”:“io: read/write on closed pipe”,“sessionID”:“q88i49ryn3r7peq34gmmzktebr”}
{“timestamp”:“2023-10-09 16:00:21.981 +02:00”,“level”:“error”,“msg”:“callback failed: not found”,“ca ller”:“app/plugin_api.go:976”,“plugin_id”:“com.mattermost.calls”,“origin”:“main.(*Plugin).handleLeav e websocket.go:455”}
{“timestamp”:“2023-10-09 16:00:23.811 +02:00”,“level”:“error”,“msg”:“callback failed: call state is missing from channel state”,“caller”:“app/plugin_api.go:976”,“plugin_id”:“com.mattermost.calls”,“ori gin”:“main.(*Plugin).handleLeave websocket.go:455”}

I don’t know what else I should provide to you so you can help me


Hello @agriesser ,

I think that you could help me with that, but maybe you need more informations so don’t hesitate to ask me for more if this is the case.

Best regards

Hello MatthieuM,

Thanks for reaching out and providing detailed information about the issue you are experiencing. It sounds like your Mattermost server works well locally but has problems with remote calls.

There are a few things that might be causing this problem. Based on the errors you’ve provided, it seems like there might be a problem related to the networking configuration, possibly a connectivity issue between the calling parties when outside the local network. Here are a few steps you can take to troubleshoot:

  1. Check Network Configuration: Ensure that all required ports (especially those related to WebRTC which is used for calls) are correctly opened and forwarded in your network configuration. There’s a chance that the calls are not correctly passing through your network due to restrictive network settings.

  2. NGINX Reverse Proxy: Verify the configuration of your nginx reverse proxy. It should correctly forward the Mattermost server’s WebRTC signals. Make sure it is configured as per the official Mattermost NGINX configuration documentation.

  3. Check Plugin Version: Please make sure you’re using the latest version of com.mattermost.calls plugin. If not, upgrading to the latest version might help solve these errors.

  4. Logs: If possible, provide the full Mattermost server logs from the timeframe around when an unsuccessful call is made. This could provide further insights into any unforeseen issues.

If you run through these steps and are still experiencing issues, don’t hesitate to provide us with the results and we’ll be more than happy to assist you further.

Warm Regards,

~Mattermost AI Assistant :robot:

[Disclaimer: This was an AI assisted response powered by Mattermost AI. Were any of the above suggestions inaccurate? Let us know by replying to this comment!]