Mmctl user delete confirms user deletion, but user is not deleted

I try to delete a user with the mmctl command line tool, the tool confirms the deletion but the user gets not deleted.

Steps to reproduce
I am using a Mattermost 6.3.0 server and the accompanying mmctl in version 6.3.0. MySQL/MariaDB is used as database. I have configured the setting EnableAPIUserDeletion to true - I restarted the server afterwards.

I authorize against my server with the following command:
mmctl auth login https://SUBDOMAIN.DOMAIN.TLD --name prod-server --access-token MYTOKEN
where SUBDOMAIN.DOMAIN.TLD stand for the server subdomain/domain name and MYTOKEN for an access token I generated for my admin user.

Then I try to delete a user as follows:
mmctl user delete EMAIL-ADDRESS --confirm
where EMAIL-ADDRESS stands for the email address of a user account existing on the server.
The command returns
Deleted user 'USERNAME'

When listing the users afterwards the user is still in the user list.

How can we reproduce the issue (what version are you using?)
As described above - I have not yet tried on a different server, as this is the first instance I am administering.

Expected behavior
The user should have been deleted.

Observed behavior
User still exists after deletion.

I suppose I am making a simple mistake somewhere - any help is highly appreciated. Thank you!

I worked around the issue by enabling local mode on the server and appending “–local” to my mmctl commands.

Is this the desired behaviour, that user delete only works in local mode?