Moving from linux to windows instance

My team was using mattermost 5.31.4 and we have been unable to upgrade past that point.

Now the server had to be moved from one vm to another and has not restarted for a very long time. It seems that some update perhaps to the linux kernel or some other service is also a problem as mattermost is borked. I am able to recover from a backup on the 13th but unable to start with current data.

With all of that said I have installed mm on windows server.( I know unsupported, but its working great.) I have done a full backup including files and dump from postgreSQL. I attempted to recover from backup but the dump file errors when attempting to import.

What is the best method to recover from my last image to the current windows mm install, also using PostgreSQL

Steps to reproduce
Following the upgrade process causes the error, have tried several versions but anything past 5.31.4 results in mm server failing to start.

Restarting the server causes mm to no longer function with check websocket port. mm service is running on the server.

Expected behavior
I would expect it to upgrade without an issue.
I would expect it to run and connect.

Observed behavior

Job for mattermost.service failed because the control process exited with error code. See “systemctl status mattermost.service” and “journalctl -xe” for details.

Unable to connect to mm service from external system after system reboot.

Hi @kiamori - Please paste the journalctl error logs for the Mattermost service here for us to take a look at.

The log was empty. I’m well past that point. Currently I would just like to be able to recover the last PostgrSQL dump to the windows install. Is that possible?

Sure, that should be possible. Please post the errors you are seeing while doing that.

No errors, I’m just not sure on the process to switch from linux to windows. I also do not see the 5.31.4 version for windows available and I assume I will need to upgrade the current system so both are on the same build, then import the db to the windows system build, then some params would need to be updated in the DB? but I am not sure which ones. Any direction on this would be great.

I was able to restore my linux mm install from the 13’th, then run psql import from the current mm that was having issues, I then also copied the ./data files and everything is working now, which tells me the issue is not mm itself but something in the CentOS environment. If I restart or attempt to update the current mm on CentOS build of mm I run into the same issues again.

The process to use Windows would be to just use the Windows build. You can directly connect to your existing DB from it. You can get the build from here:

1 Like