My board is gone

After I edit Nginx config to “client_max_body_size 500M” I command “mmomni reconfigure” and “sudo apt update && sudo apt upgrade” (hoping mattermost version will update) My board menu disappear

Mattermost Version: 6.5.0
Database Schema Version: 6.5.0
Database: postgres
Install by Omnibus

I tried

but not work

And I can’t install board plugin.Will there be a problem if I install over the old one?

I’ve tried enterprise edition and when the trial expired It’s not coming back to team edition.

Hi dogtorshepherd and welcome to the Mattermost forums!

What you’re seeing here looks like a permission issue on your installation. Can you please login via SSH (as root or run sudo -s then to elevate to a root shell) and run the following command?

find /opt/mattermost ! \( -user mattermost -o -group mattermost \)

This should give no result, if everything is OK. If you’re getting a list of files and folders here, it means that some of the files and folders in there belong to a different user account and this might cause troubles.
If that’s the case, please try:

systemctl stop mattermost
chown -R mattermost: /opt/mattermost
systemctl start mattermost

And see if the problem persists.
Also the Boards version you have here is very old, but I’m not sure if this was the most recent version available for Mattermost 6.5.0 back then, but I’m wondering why you’re still on 6.5.0 since you did run apt upgrade which should have brought you to Mattermost 7.2.0.
Let’s focus on the plugin, first.

Reinstalling the plugin will not cause any issues, because upon removal, the database tables storing the data will still be left intact and therefore removing a plugin will not remove data, but as always, make sure you have a current backup before working on your systems.

If you did not have any permission issues, then please login to your “System Console”, sections “Plugins”, menu item “Plugin Management” and try to disable and re-enable the boards plugin there. If this also does not help, then remove it and install the latest version out of the Marketplace.

With regards to the edition you’re seeing: Mattermost omnibus installation bundles the free enterprise edition, you cannot downgrade to the team edition here and in fact, this is also not necessary, since the unlicensed enterprise edition has the same features as the team edition, so you can leave it like this.

Your About screen looks strange, though - the database schema version should not be 6.5.0. Can you please post the output of the following command after a fresh restart of your Mattermost instance?

eval $(grep ^MM_LOG /etc/mattermost/mmomni.mattermost.env)
tail -100 ${MM_LOGSETTINGS_FILELOCATION:-/opt/mattermost/logs}/mattermost.log