New Docker install, unable to create first Mattermost System Admin user

New Docker Install of Mattermost on unraid. installed and i visit the url of mattermost and i am met with a log in screen and i’m unable to create first Mattermost System Admin user

Steps to reproduce
using the lastest version of mattermost

Hi matda59,

can you please share a link to the installation instructions you used in order for me to verify the state of your deployment? Thanks.


I have same problem as @matda5. Only hint I can find in logs is following error:

“level”:“error”,“msg”:“Failed to get system bot”,“caller”:“app/post.go:2080”,“error”:“GetSystemBot: List of admins is empty.”}

Yes I get the same error in my log, @agriesser, I just chose the mattermost unraid community image, did the

sudo chown -R 2000:2000 ./volumes/app/mattermost

Hi again,

I don’t know what unraid is and where to get the community image from, this is the reason I’m asking for links and detailed instructions in order to be able to reproduce the problem you’re seeing here. I tried some googling and found some things, but I’m still unsure if this is the installation method you followed so even if I would go down the road in order to see what you’re seeing, I cannot be sure that this is the right way.

Anyways, let’s assume they enabled mmctls local mode in their image, then you should be able to create the first user account using the CLI, at least let’s give it a try:

docker exec -ti <id of mattermost docker container> mmctl --local user create --email --username yourusername --password yourpassword --system-admin

If you get an error message, please share it here.
If the error message is about the local mode not being enabled, then you need to enable it first.

sed -i -e 's/"EnableLocalMode":.*/"EnableLocalMode": true,/' volumes/app/mattermost/config/config.json
docker restart <id of your mattermost container>

Worked for me! Thank you very much for your help!

We have also provided a bug fix for this now in v7.7.1 dot release.

1 Like

updating the docker container fixed this issue for me!