Nginx Configuration [solved]


I followed the install documentation on the mattermost docs here:

I’d like to install mattermost and postgres on one machine only though. Therefore I replaced the suggested IP addresses with in all config files. (Naturally not in the network configuration files.)

The installation is only supposed to work in a local network for testing purposes.

Following the guide for configuring nginx I end up with nginx displaying the standard welcoming site. I am thinking previous steps in the how to work fine. What am I missing?

OS: Debian Jessie.

Thanks in advance

Hi @ichi-no-eda,

Have you tried curling localhost to see if that works? For example curl http://localhost:8065. That should work if Mattermost is running, regardless of the state of NGINX.

If that doesn’t return a Mattermost HTML page, then Mattermost probably isn’t running, possibly because it failed on start-up. Inside the directory where you installed mattermost there should be a log file under mattermost/logs/mattermost.log. Open up that file and look for any errors. If you see any they might help you identify the issue. You can post them here as well if you’d like some more help :slight_smile:

Also if this instance is only for testing, and the clients that are going to be connecting to your Mattermost server all have the ability to connect directly to it, then you can skip NGINX if you don’t need SSL (HTTPS) connections. You can just point your browser at and it should work correctly

Let me know if that helps and if you have any more questions

Hi jwilander,

I did reinstall everything from scratch and in fact realised, that when I start mattermost with systemctl the service wouldn’t run.

The reason was, when I first executed platform, I did so as root. So the log file was created and only writable with root rights. Systemd though starts the mattermost.service with the user mattermost and thus mattermost couldn’t write into the log file and exited.

Thanks for your help jwilander

1 Like