No teams are available to join. Please create a new team or ask your administrator for an invite

I configured the server, but when I access it for the first time it tells me that I do not have a channel, so I can contact the administrator, how can I get around this?
I’ve tried some tutorials, but none for Ubuntu 16.04 installations, could anyone help me?


Hey there,

I have the exact same Problem: installed Mattermost 5.0.0 (Ubuntu 16.04) with MySQL 5.7 and I can create a first account but after that nothing happens - I can’t create a Team and got the same message as the poster above.

I tried to create a Team with the command line tool > worked, but then I tried to give adminstrator rights to my initially created account and nothing happens. Ist still a user. What can I do?

I used the following commands:

./mattermost team create --name myteamname --display_name “my team”
./mattermost team add myteamname myusername
./mattermost roles system_admin myusername

Any help? :slight_smile:

I found the problem for me: I forgot to enable the apache 2 module proxy_wstunnel (you will also need proxy and proxy_http)
Now it works and I can create teams. :slight_smile:

Hi @cezarbehrend - let me know if the above helps you ^

I also found this thread that might help: "No teams are available to join", how do I create one?

If neither works, just let me know!

This created a team for me and added it, but it did not add me to the system_admin role.

It appears there is a setup step related to an Apache port which isn’t clear from the documentation.

I am yet to discover how to set it up, but others have asked this question and it appears that there is some sort of admin console that is reliant on another service.

I will come back and add some notes when I work it out.

hi i run mine on Qnap device

had same issue, what helped me is to simply go to

1 Like