Plugins disabled (caused by SELinux)

I have created a new MM instance (self-hosted) for testing which has issue with plugins.
The plugins are ‘enabled’ via the System Console and config.json file.
When I start MM, I am getting the following error:
info [2024-04-30 13:22:01.780 +01:00] Starting up plugins caller=“app/plugin.go:191”
error [2024-04-30 13:22:01.780 +01:00] Failed to start up plugins caller=“app/plugin.go:199” error=“mkdir ./client/plugins: no such file or directory”

The directory is here and has the same permission and ownership as the rest of the application directory.
When I go to the the System Console/Plugins section the following error appears as well:
info [2024-04-30 13:23:29.602 +01:00] Plugins have been disabled. Please check your logs for details. caller=“web/context.go:113” path=/api/v4/plugins request_id=6yrqd8bddfyktjfe7857a948uc ip_addr=X.X.X.X user_id=iyriqi4cwin9xyon5ic1d1y36c method=GET err_where=GetPlugins http_code=501 error=“GetPlugins: Plugins have been disabled. Please check your logs for details.”

Any thoughts or suggestions where to look?
Many thanks

So found the issue…SELinux was being enforced (which was also stopping my service from running).
setenforce 0 to disable it and plugins are now enabled and allow I can get to the Marketplace.
However - I should be able to run the service with SELinux enabled.
I will continue to look, but any ideas on getting the mattermost.service now to be allowed to run with SELinux enforced?

OK - resolved by running:
sudo restorecon -R /opt/mattermost
Found this solution on the following link -