[SOLVED] Upgraded to 4.5.0 from 4.3, unable to upload zoom plugin - error - Plugins have been disabled

Hello everyone,

I am having an issue with MM 4.5.0 Zoom plugin integration,

earlier I was running MM 4.3 which I upgraded to 4.5.0 today,

I followed official upgrade guide, everything works perfectly, except Plugins, I thought zoom plugin comes bundled with MM 4.5.0 but I couldn’t find it in my installation,

anyway I enabled plugin, and plugin upload setting from plugin configuration, then in management I tried to upload zoom plugin, but after upload it says Plugins have been disabled.

In Log file I am getting these error:

[2018/01/11 12:21:26 UTC] [EROR] /api/v4/plugins/webapp:GetActivePluginManifests code=501 rid=ajrq9dyd73yajjd48jydrcrfkc uid= ip= Plugins have been disabled. [details: ]

I tried to disable plugins then restart service, cleared(Purge) caches, restarted browser - but no results.

I thought it may be a file permission issue but it is fine I believe - https://cl.ly/om6u

here is my MM info - https://cl.ly/om8B
I am running centos 7

I have the same issue. I have enabled plugins and restarted but am still getting this message. Did you find a solution?

Hi @mdmd
Yes, I got solution for this Issue, Let me explain what I did here
First, I checked logs for Startup errors, I got these errors in my error log
as error was saying no directory inside client folder, I created a plugins directory inside client,
but it didn’t solved my issue,

Then I Checked my Mattermost.service file and changed WorkingDirectory=/opt/mattermost/bin – to – WorkingDirectory=/opt/mattermost
this eventually solved my issue,

once you save this file, you have to reload daemon, and restart mattermost service, then wait for few minutes while your MM restarts.
I hope this helps.

1 Like

Thank you – yes, changing the working directory (and manually creating the client/plugins directory) did the trick.