[SOLVED] A problem with plugins start up with docker installation


I had mattermost 4.4 installed with docker by this instruction: https://github.com/mattermost/mattermost-docker. I’ve updated it today to 4.5 and now see this error in logs: [2017/12/19 23:02:02 MSK] [EROR] failed to start up plugins: mkdir ./client/plugins: no such file or directory. I’ve tried to make client directory everywhere, but still have no success.

Please, help to solve this problem. Thanks.

Same circumstances and issue.

Hi @semin-lev, @SOb_S

Thank you for your feedback,

Is this documentation helpful?

Hi @lindy65

Thank you for your reply, but It doesn’t help because mattermost was installed and worked correctly before the update.

Hi @semin-lev @SOb_S

Ah, sorry, I missed that your instance had been working properly before upgrade.

@pichouk are you able to help with this issue?

I got the same error when I upgraded my own instance. My quick workaround was to disable Plugins on my Mattermost system (go to System Console > Plugins (Beta) > Configuration).

@semin-lev If you are not using Plugin on your server, I suggest you to disable it. This is not satisfactory workaround but since Plugins are a beta feature, I didn’t investigate more for now.

I just opened an issue on our Github to made Plugins works, but considering the error log (a folder didn’t exists), I think people using Mattermost without Docker should have the problem too.

Hi, @pichouk

Yes, I disabled plugins too to make the instance worked. But I want to try Zoom plugin… Okay, thank you. I’m going to observe the issue.

Thanks @pichouk :slight_smile:

@semin-lev @SOb_S,

I’m going to close this issue off here and we can track via the GitHub issue linked above.

FYI, a PR just fixed this issue. It should work now (but you need to upgrade your docker image of course) :slight_smile:

1 Like