Private "Someone" channels after migration


After the migration of our server from 4.8.4. to 4.10.1 I myself (as one of the admins) and some of our users noticed that private “Someone” (in German “Jemand”) direct message channels did appear and clicking on the X to remove them from the list does not work anymore.
These channels do show the remaining own posts (or even just an empty channel if the own posts were deleted also) of chats with people who were completely deleted from the database with their postings by executing the following command:

docker-compose exec app platform user delete --confirm

In release 4.8.4 and in earlier releases we were able to click on the X and the channels did disappear from the private direct messages channel list.

Is there perhaps a way to completely remove those private message channels from the system that do only have one remaining participant?

Steps to reproduce

I would assume by deleting users from the database with the command above

Expected behavior

Clicking on the X should remove the channel from the list as it worked in former releases

Observed behavior


Hi @GuidoD! Thank you for reporting this.

There was another similar report a few days ago on our nightly build server in the Bugs channel - you can join to check out the discussion!

The user who reported it solved the issue by adding the CloseUnusedDirectMessages option to their config.

Let me know any questions if this doesn’t help!

1 Like

thanks for the hint, I will check it later today when I have direct ssh access to the server.

well some more problems with these "someone"s.
We do have users that had the persons under their favorite channels and now they have these “someone” channels that cannot be removed.
CloseUnusedDirectMessages does only help for the someones in the direct messages section.
Is there also a solution for the favorite channels?

Or will the problem itself be fixed in a newer release so that we can even set CloseUnusedDirectMessages back to false?

Hi @GuidoD! Thank you for reporting this.

I created a Jira ticket for our team to investigate:

1 Like