Production Installation - not starting

I’m having an issue while following the Ubuntu production installation running on a Ubuntu 14 VPS

when I run
sudo start mattermost
it returns
start: Job failed to start

if I run /mattermost/bin ./platform I can successfully run mattermost.

Any ideas why the startup script would not be working?

Can you confirm you have created the startup script correctly as referenced in step 9?

Yes, I have tried with that verbatim as well as other modifications of the script I have found elsewhere

Is /home/ubuntu/mattermost where you have installed Mattermost?

i face the same problem. then i change the config into

start on runlevel [2345]
stop on runlevel [016]
limit nofile 50000 50000
chdir /opt/mattermost/bin
setuid mattermost
exec ./platform

i am installing using this tutorial

Thanks a lot for sharing this topic.i am very interested to read this blog.i got a clear idea about this a staff in business related company has to done a online fee payment process.for more details are included in online fee payment school