Setting up SMTP

Can’t send emails because there is no value for “sender”

Steps to reproduce
Not entirely certain, I have entered in my SMTP server and credentials, and it connects but I get this error.

Connection unsuccessful: Connection unsuccessful: failed to set the from address: 530 5.7.1 You ( are not authorized to send mail as the null sender (<>)

Other things to note… I did not end up going through the standard install path as I couldn’t make the non-SSL install work properly. It would fail on the nginx restart on focal/ubuntu 20.04. Looking at systemd, nginx was up fine, but the install script of mattermost-omnibus failed out.

Afterwards I setup postgres myself and got it running after some time with the docs. I considered rebuilding the container and using the tar method for installation, but when it started working with some postgres tweaks I’ve tried to just go with it and don’t see anything on the tarball path that would help this.

Expected behavior
I expect the SMTP test to function after I enter a good server and credentials. I can’t find a setting for the sender address in the GUI or config.json.

Observed behavior
No joy in email notifications. No joy searching for answers to this issue on this forum or search engines. Maybe my search-fu is weak on the topic.


this error message is not being generated by Mattermost, but by your SMTP server. Are you using your provider’s server or a locally installed mail server (like Postfix or the like)?
What Port are you using for the SMTP server inside the mattermost configuration?

Also please make sure that you filled out the values for “Notification From Address”, “Support Email Address” and “Notification Reply-To Address” in the System Console → Site Configuration → Notifications Section.