[Solved] Android app fails after connecting


Android app will connect to the server when the certs are installed but after X amount of time it will stop “connecting” to the server but the app still pushes notifications.

Steps to reproduce

App version: 1.17.0, using Lets Encrypt cert, but not enabling lets encrypt due to corporate network restrictions.

Expected behavior

Certs are accepted in my browser (firefox, chrome, brave, vivaldi) but not on the app on android. After initial installation of certs, the android app will happily connect to the server but afterwards the app will stop connecting but will still push notifications and updates.

Observed behavior

No error messages, just doesn’t update the screens messages. Continually showing the connecting bar and the spinning wheel. I am using a .tk domain if that is an issue.

Hi @that1guy,

Please take a look at our troubleshooting docs here:

Thank you, the issue was that the cert chain was “incomplete”. Mattermost I guess required me to use the “full-cert-chain.pem” instead of just the “cert.pem”. So it worked in everything except the mobile app. Weird but it’s fixed. Thanks.

1 Like