[SOLVED] Cannot switch users login method from SSO to Email/Password


Cannot change a user account from GitLab SSO to Email/Password login.

Steps to reproduce

  1. System Console > Users > Dropdown of a user > Switch to Email/Password
  2. Enter a password and save

I’m using Mattermost 4.3.0 (4.3.2) with postgres in the GitLab docker container (omnibus).

Expected behavior

I expect the user login method to be switched to Email/Password and the entered password to be set for this user.

Observed behavior

Error message that the current password was not entered (though there is no current password and also no input for a current password).

Screenshot (in german):

Also notice the missing translation of the input field name (current_password).

Entry in the log

Invalid or missing current_password in request body [details: ]

Hi @dehalion, is this when the admin is trying to switch their own account to email/password? We have a bug filed on that but I believe it should work for other users

Yes, you are right. I tried to switch my own user first (which is admin).
If there is already a ticket for this you can close the issue here.

Thanks @dehalion,

I’ll close this off for now as we have a ticket filed to track.