[SOLVED] Failure to jump to old message from permalink or search


Jumping to an old message from the search area sometimes fails and just displays “Loading …” forever.

Steps to reproduce

  • Mattermost 4.1.0
  • Chrome or desktop client
  • Use the search box and find posts from several months ago
  • Click on the jump link

Expected behavior

Should jump immediately to the old message. (Before upgrading this worked almost instantly)

Observed behavior

Channel content is replaced by “Loading …” forever.
Nothing in the logs.
Navigating via permalink has the same problem.

Yeah unfortunately there’s an issue when jumping to an old message…we have a ticket for it here: https://mattermost.atlassian.net/browse/PLT-7416

Thanks - I have voted. This one’s pretty bad for us since we use search and permalinks quite a lot.

I must say though, I think that’s a pretty high-priority bug (marked as medium priority right now). The ability to search and share permalinks is quite central to the value we get out of mattermost…

Hi @gubbins,

The PR for the fix has been merged :slight_smile: so this should be fixed in the next release on Sep 16th.

1 Like

I saw that! Thanks for the heads up.