[SOLVED] Favicon and Cache

I have swapped out all the favicons in the /opt/mattermost/client/images/favicon directory but the original is still loading.

I had cleared all local caches and restarted the server.

Running latest stable version on Ubuntu 16.04 with nginx and postgres

Any ideas?

UPDATE - So I have waited and also cleared the nginx cache and still no luck.

Is this an Enterprise only kinda of thing?

I don’t think changing favicon is EE only (although I may be wrong). Have you checked the html source in your page to ensure the links are pointing at your new images?
I don’t think it would be an enterprise issue as per : https://github.com/mattermost/docs/issues/1006

When I inspect the page this is what is getting called in the head section

“link rel=“icon” type=“image/png” sizes=“32x32” href=”/static/files/f3a30fd11b4f31d5b405a52bb18942ae.png"

That references a directory called “static/files” and a file name that looks generated on the fly. I can’t see that file structure in my /opt/mattermost directories.

I have nginx out front and am a bit confused on exactly where the webroot is.

The file would be located under /opt/mattermost/client/static/files. Its filename is generated when the web app is built so it’ll likely change whenever you update Mattermost.