[Solved] Focalboard v7.11.3 won't start after upgrade from 7.0.1


I used Focalboard 7.0.1 and (tried) to update to version 7.11.3 - after updating it - Focalboard won’t start anymore. The issue is reproducible.

What’s my problem?
I lost access to my focalboard since I cannot start the program with the (old) “focalboard.db” saved in documents\focalboard. I am not able to recover anything anymore :frowning:

What am I using:
Windows 10 - Focalboard local version (downloaded via github).
I am using Focalboard alone - no server or whatsoever. Saved in a Folder.

What did I do:
I downloaded the latest version of Focalboard v7.11.3 and double-clicked on the Focalboard.exe.
Thats it. Focalboard won’t start.

What (might) be wrong?
The file “focalboard.db” (located in documents/focalboard) changed the minute after I tried to start the new version. If I delete the current “focalboard.db” and start the program again - it works just fine.
However, I cannot simply override the newly (and empty) created “focalboard.db” with my old one.

How do we reproduce the issue?
Start a clean Focalboard 7.0.1. Open a project. Close the program. Start the new v7.11.3. Thats it.

What did I do already?
I checked if I could see any changes in the database using DB Browser SQLite. However, I do not see that starting the new version of focalboard changed the file.
I tried to delete the documents\focalboard folder and replaced the focalboard.db with the old one, which includes all of my projects. It won’t start.

I would appreciate it a lot if anyone could help me to recover my (old) focalboard.db, so I can access my projects.


solved by copay and paste of the (old) database blocks to the new one via sqlite Studio

1 Like

Yay! Glad to hear you got it figured out, Spamkg!

Thanks so much for following up to let us know, and welcome to the Mattermost community forums!