[Solved] How enable webhook API creation in mattermost


I, how can enable the webhook creation using API? Mattermost always response me the following text:

Outgoing webhooks have been disabled by the system admin.

My configuration using says:

    "EnableIncomingWebhooks": true,
    "EnableOutgoingWebhooks": true,

And the system are the following

Mattermost Version: 5.5.1
Database Schema Version: 5.5.0
Database: mysql

Steps to reproduce

I using a curl request like this:

curl --location --request POST "https://omnichat.democrm.com.ar/api/v4/hooks/outgoing" \
  --header "Authorization: Bearer XXXXXXXXXXXXXXX" \
  --header "Content-Type: application/json" \
  --data '{"team_id": "XXXXXXXXX","channel_id": "XXXXXXXXXXX","description": "","display_name": "send to web service","trigger_words": [],"trigger_when": 0,"callback_urls": ["https://miwservicetest.com/v1/out"],"content_type": "application/x-www-form-urlencoded"}'

Expected behavior

Creation of webhook outgoing success.

Observed behavior

Mattermost returns to me the following response:

{"id":"api.outgoing_webhook.disabled.app_error","message":"Outgoing webhooks have been disabled by the system admin.","detailed_error":"","request_id":"iqztco7t43gcmep999c4csr35r","status_code":403}

I found the error, it is caused when the team channel not have enough permissions, or the channel is not public.

1 Like