[Solved] Local only Installation - How to get rid of "Please check connection, Mattermost unreachable"


as an aboslute Mattermost-beginner, i installed the current Mattermost release on a HYPERV-VM on Ubuntu 22.04.3

We like to access our Mattermost installation local only, so i just installed the mattermost-server with postgres, no reverse-proxy, http only. → I hope this isnt too exotic :slight_smile:

When i access my mattermost instance via Firefox or App (by ip or by local dns-name mattermost.company.local:8065), i can log in and everything seems to work fine, but after 20-30s the red bar appears:
Please check connection, Mattermost unreachable. If issue persists, ask administrator to [check WebSocket port

I don’t understand what this is suppose to mean, obviously i can reach my mattermost, so its not unreachable.

What can i do to turn that warning off?

Or where can i look deeper into the problem?

Greetings, Micky

Hello Micky,

Thank you for reaching out and welcome to the Mattermost community! We are here to help you solve your issue.

The problem you’re experiencing might be related to websockets. Mattermost uses websockets for real-time updates, and it appears that your browser can reach your Mattermost server initially, but cannot maintain the websocket connection.

First thing to consider, even if your Mattermost server is set up to be accessed locally, you must ensure that traffic on the port 80 for HTTP and port 443 for HTTPS is allowed (even though you mentioned you are using HTTP only). Traffic on these ports is necessary for the creation and maintenance of websocket connections.

Secondly, could you check whether your system firewall or security group settings might be preventing websocket connections?

Additionally, please check that your config.json file in the Mattermost directory has the correct SiteURL set. It should match the exact site URL that you are using to access Mattermost (e.g. "SiteURL": "" or "SiteURL": "http://mattermost.company.local:8065")

Lastly, you can access Mattermost logs to get more information about the problem. You can find them in the logs folder within the ‘mattermost’ directory by default.

I hope this information helps get you started on the troubleshooting. Please don’t hesitate to reach out if you need further assistance.

~Mattermost AI Assistant :robot:

[Disclaimer: This was an AI assisted response powered by Mattermost AI. Were any of the above suggestions inaccurate? Let us know by replying to this comment!]

1 Like

Micky - HTTPS & WSS are different origins. This is something that began being enforced in ~7.8 for security. You may need to allow cross-origin requests: Integrations configuration settings — Mattermost documentation