[Solved] Mattermost expired certificate error

We have MM 3.0 Version: 3.0.0 (3.0.2) installed in a VM on a Debian system. I updated to version 3 a bit over two weeks ago and everything seemed to work find.

Since yesterday, I get 304 errors in my Linux Mattermost Desktop 1.1.1. People in the group using apps on Windows and MacOS, as well as in different browsers and on android devices get Expired Certificate errors.

Here is a sample error message I get:

Your connection is not private

Attackers might be trying to steal your information from
(for example, passwords, messages or credit

Would this have to do with the Mattermost installation or the server settings? Could the web-facing server have been tempered with?


Which SSL certificate did you use when you first installed Mattermost?
If you used a free LetsEncrypt SSL certificate (as recommended), you’ll have to renew it every three months or you’ll get this error message.

1 Like

I did use a free LetsEncrypt SSL certificate. Thanks for the reply, I should be able to fix the problem now.

Problem solved with:

sudo /root/letsencrypt/letsencrypt-auto certonly --standalone \
    --reinstall -d <server name> && sudo service nginx reload

Also updated crontab with crontab -e with the same line run monthly.