[Solved] Running Ubuntu 22.04 on 64 bit computer, Software Updater fails due to Repositories problem. (Issue #25483)

This looks to me like a bug. I’m not trying to upgrade Mattermost. Ubuntu (based on Debian) is the leading desktop Linux-based Operating System. Software Updater is a GUI app which is the standard way to update the OS and all apps. The https://deb.packages.mattermost.com (when doing ‘sudo apt update’ in CLI) repository is presumably created & updated by Mattermost devs. I think that the problem actually is in that repository. Running Ubuntu 22.04 on 64 bit computer, Software Updater fails due to Repositories problem.
Software updating using CLI works as shown below but there is a warning on mattermost repo: N: Skipping acquisition of configured file ‘main/binary-i386/Packages’, as repository ‘https://deb.packages.mattermost.com jammy InRelease’ doesn’t support architecture ‘i386’.
Not able to supply complete CLI for ‘sudo apt update’ due to limitations of being a new user.

I run the same setup and had no issue when updating to mattermost 9.2.2.

Heya John,

Thank you for bringing up this issue, we value your contribution to the Mattermost community. I understand that you’re facing a problem with Software Updater on Ubuntu 22.04 when trying to update via the Mattermost repository.

The warning message you’re seeing about skipping acquisition of main/binary-i386/Packages suggests that it’s trying to get i386 (32-bit) packages from the Mattermost repository, which isn’t supported as our deb repository only provides 64-bit packages. This could be the reason why you’re facing issues with Software Updater.

A helpful step you can follow:

Add [arch=amd64] after deb in your sources list for Mattermost. Your entry should look like this:

deb [arch=amd64] https://deb.packages.mattermost.com ./

Now, run sudo apt update again and that should solve your problem. Please note, this will tell your system to only request 64-bit packages from the Mattermost repository.

Alternatively, you can remove the i386 architecture from the list of architectures that your system is configured to fetch packages for:

sudo dpkg --remove-architecture i386

Please exercise caution as this will prevent your system from fetching any further updates for 32-bit packages. Only apply this if you’re sure you won’t be needing 32-bit package updates in the future.

I hope this helps. Let me know if you have any additional questions or concerns.

~Mattermost AI Assistant :robot:

[Disclaimer: This was an AI assisted response powered by Mattermost AI. Were any of the above suggestions inaccurate? Let us know by replying to this comment!]

Hi John,

Thanks for your informative reply.

Do you expect 2 lines for Mattermost repos, as shown below?
john@Desktop:/etc/apt/sources.list.d$ cat mattermost.list
deb [signed-by=/usr/share/keyrings/mattermost-archive-keyring.gpg] https://deb.packages.mattermost.com jammy main
john@Desktop:/etc/apt/sources.list.d$ cat mattermost_stable.list
deb https://deb.packages.mattermost.com stable main

I put the "[arch=amd64]" bit immediately after the deb in both the lines below. But "apt update" then objected with:
E: Malformed entry 1 in list file /etc/apt/sources.list.d/mattermost.list (URI parse)
E: The list of sources could not be read.

PS There is no i386 architecture though there is a foreign architecture for i386:
john@Desktop:/etc/apt/sources.list.d$ sudo dpkg --print-architecture
john@Desktop:/etc/apt/sources.list.d$ sudo dpkg --print-foreign-architectures

In my last post, I said that putting [arch=amd64] before deb in the mattermost entry in /etc/apt/sources.list.d//mattermost.list (i.e. deb [signed-by=/usr/share/keyrings/mattermost-archive-keyring.gpg] )caused a problem for “apt update”. The problem was I did that incorrectly. Apologies for my misleading earlier.
I looked at another computer where I installed mattermost more recently where Ubuntu’s Software Updater works Ok and it only had one entry for mattermost i.e. the stable one. So I deleted the one without stable and put [arch=amd64] in the one with stable and everything now Ok.

1 Like

Huzzah! Thank you so much for following up with the solution, John!