[SOLVED] Upgrade Problem 3.6.2 to 3.8.2 Team Edition


I’m a relative newcomer to Mattermost but a total convert! I’m just sizing up my first upgrade since we deployed 3.6.2 on Ubuntu 16.04 and mysql.

When I look at the upgrade guide, alarm bells ring in my mind that the guide is for a later version than the one we are on. One of the reasons for this is that it states that “sudo stop mattermost” should be used to stop the service…surely this is incorrect?

We took a snapshot of our VPS yesterday and ran a test update. To summarise, we stopped the systemctl service, extracted the new version to /opt/mattermost, replaced config.json and started the service again but this didn’t work at all. We didn’t see any error messages but mattermost would not start. Please do correct me, but I think we followed the upgrade guide as best we could.

Am I missing something really obvious here?

Many thanks,


Hi Dan

My first thought is that maybe the new install files have the wrong owner and group. They might be set to root:root if you used sudo while extracting the tarball, or maybe your own user and group if you didn’t. In either case, Mattermost might have trouble starting.

I’ve been working on new upgrade documentation, which you can see here: https://github.com/mattermost/docs/blob/301aa33d23fc6fad9617766be1ff487c9763073c/source/administration/upgrade.rst.

Let me know if you succeed with these instructions, or if you find areas that need improvement.

Hi Jeff,

I’m a bit embarassed that I didn’t think to check which user Mattermost runs under.

Thanks for the heads up. Will take a closer look later today. The new upgrade documentation looks great, I’d be very happy to let you know if I find anything.

Will post back here once I’ve spent some time digging…

Thanks again,


Hi Jeff,

Your new guide works perfectly.

Mattermost was running under the user mattermost, chown solved the problem as you suggested.

Thanks for your help.


That’s great! Glad to be of help.