[SOLVED] Slash Command Issue: Address Forbidden after v4.2 Update

After upgrading to 4.2, custom slash command is no longer working. This custom slash command is pointing to the same box as the Mattermost Server.

I saw the breaking changes @jasonblais posted.

Would the following “Breaking Change” for v4.2 be causing the issue? https://docs.mattermost.com/administration/changelog.html#breaking-changes

Here is the error message I am receiving:
Post http://localhost:9090/api/webex: address forbidden

If this is the case, would the solution be to add the following to the Server Settings? Is the port needed?:
"AllowedUntrustedInternalConnections": "localhost"

@ericfaris Yes, that sounds like the issue. "AllowedUntrustedInternalConnections": "localhost" should resolve it, but let me know if not.

1 Like

@jasonblais That was the issue. Thanks. :+1:

I did recently update to 4.7 and all my slash commands start to fail. I realize that was the issue, but my mmost server is in an internal and isolated network so I should allow any address to use slash commands. I tried *, 10.0/8, but no one works.

How can I allow all IP addresses or disable this feature. Thanks.

Just fixed, with but 10.0/8 its a good notations and is’t no supported

1 Like