[SOLVED] Web Interface doesn't load


I did a fresh install via docker on Xubuntu 16.04 LTS and when I launch localhost:8065 in a web browser I just see a loading bar, however, the webpage never loads.

Steps to reproduce

Mattermost version 3.9.0

All I did was follow the Docker tutorial on the website link. After that the webpage never actually loads.

Expected behavior

The web interface never loads, just hangs at the loading screen.

Observed behavior

No error code, just a loading bar that never loads anything.

Thanks @spectre216,

Can you share a link to the install guide you followed? Just want to make sure it wasn’t an old guide you followed by accident.

I had the same issue when upgrading from 3.8 to 3.9 Team Edition. Now i am stuck on 3.8
By using Apache i didnt have to opportunity to Change this one (* below) according to the changelog, as it is only described for nginx…
Could that possibly be related?
Do you have a reference how that below mentioned line should be like in Apache?

(*) https://docs.mattermost.com/administration/changelog.html
• If you’re using NGINX as a proxy for the Mattermost Server, replace the location /api/v3/users/websocket { line with location ~ /api/v[0-9]+/(users/)?websocket$ { in the /etc/nginx/sites-available/mattermost NGINX configuration file.

@githubkoma We have a pull request here that adds an Apache configuration guide for Mattermost:


Would that be helpful?

We’d also love to hear if you’d have any comments or feedback on the proposed Apache configuration guide.

that one worked for me!
now its working for me with 3.9.0 on apache!

(used this: https://github.com/mattermost/docs/pull/1200/files?diff=unified)

many thanks to all

1 Like

Glad your issue is solved @githubkoma!

I’ll close this off for now…

Sorry for the late response, I followed the instructions on the downloads page for mattermost.

@spectre216 Are you using a proxy? Any error messages you can share (either in the console or in the server logs)?