[SOLVED] Websocket Apache 2.2 -> Forwards to /ws:/


I updated to the latest mattermost (3.10.0). I want to use my Apache 2 (2.22.2) with my own SSL certificates. I use this Apache2 with SSL configuration from your documentation without the “Require all granted” lines, because they are for Apache 2.4.

Because I can’t update to Apache 2.4, I had to setup the proxy_wstunnel manually.

All requests in Mattermost are answered properly, but ‘https://mm.analyse-konzepte.de/api/v3/users/websocket’ gets a 301 to the location: “/ws:/”. When I enter the URL ‘mm.analyse-konzepte.de/api/v3/users/websocket’ in my browser, it takes me to: mm.analyse-konzepte.de/ws:/ and obviously i get an error.

Expected behavior

I would expect, that https://mm.analyse-konzepte.de/api/v3/users/websocket forwards internally to

Observed behavior

Thanks @crille1006!

Given the Apache2 guide is unofficial and community-maintained, I opened your issue in the docs repo and nudged a few members who have worked on the guide: https://github.com/mattermost/docs/issues/1295

Thanks for opening this issue at github.

Hi @crille1006,

I’ll close this issue off here and we can track it in GitHub.