Stuck to localhost


Since one or two month, (Mattermost desktop app update), when i’m trying to connect to (docker infrastructure + traefik tgrough port 80), Mattermost allways try to connect to (http://localhost:8065).

When i’m trying in browser it’s ok, Mattermost is displayed correctly.

Is someone have any idea why ?

Thanks in advance,

Hi Nono44 and welcome to the Mattermost forums!

This behaviour has been introduced in a recent desktop app update (I think it was 5.1) and the desktop app now always tries to connect to the configured SiteURL. Not sure what deployment method you’re using, but since you said you’re using docker, you’re probably using the docker compose method with the .env files? If so, you will find the following two relevant configuration options in it:

# Domain of service

If you have your own setup, make sure to set the environment variable MM_SERVICESETTINGS_SITEURL to the URL your server runs on (including the protocol and potential subpaths).

Hi @Nono44 ,

just trying to follow up here - were you able to solve your issue?