I can't connect my server via apps but can on web browser

I can’t connect my server via apps but can on web browser

Steps to reproduce
Open Mac app (5.2.2), type my server address with port and server name

Expected behavior
I should be able to connect my server. (It works on web browser)

Observed behavior
Nothing happens (no error message)

No SSL setup so I connect with HTTP on web browser

Hi Yohan and welcome to the Mattermost forums!

Has this always worked and is this a new development or is this the first time you tried? Any updates to either the server or the desktop app related to the malfunction?

Connecting to the server using http only should work, but there has been a change with 5.1 or 5.2 (always forget the right version) where the desktop app redirects to the server configured SiteUrl after login. Can you verify that the variable SiteUrl in your server is set to the URL you’re connecting to from the desktop app?

I invite someone and the one get this error


your siteurl says https://team.yohan-server.synology.me and your server obviously does not support the https protocol, so when you enter http://team.yohan-server.synology.me:8401 in the desktop app, it will redirect you to the value it receives from the SiteUrl and this URl is unreachable.

I assume you’re running the docker deployment on your Synology NAS, right? If so, there should be a configuration file (maybe .env in the docker directory?) where you can modify the environment variable MM_SERVICESETTINGS_SITEURL to point to http://team.yohan-server.synology.me:8401 and then it should work.

With regrads to the iOS app: I’m pretty sure it does not support http at all, this might be a restriction from the Appstore, so I think overall it would be better if you woulud also set up a certificate for your Mattermost server on the synology. You can either do that directly in the Mattermost application (in the system console, you can set up let’s encrypt) or you can use a reverse proxy container (nginx, f.ex.) in front of it and do the SSL offloading there.

The invite URLs are also generated based on the SiteUrl configuration variable, so this is definitely related.

1 Like

Right, docker deployment on my Synology NAS. I think your solution(edit the configure file) would solve the issue.
Overall I agree with you it would be better just set up a certification for my server
Is there any guide link how to get Let’s Encrypt in the Mattermost application? I’m unable to click Use Lets Encrypt as ‘ture’ on system console

Thanks for your help! :+1:

Did you also enable the “Forward port 80 to 443” setting? It is required for this feature.

I’m unable to click true for “Forward port 80 to 443” setting

After I update this as your guide
MM_SERVICESETTINGS_SITEURL to point to http://team.yohan-server.synology.me:8401
I can connect my Mattermost with my Mac app!! :laughing: Awesome support! Thank you so much agriesser!

You’re welcome, glad to hear you’re up and running now!

1 Like