The database schema version and model versions do not match


I tried to upgrade my Mattermost instance (docker-compose) from 5.33.3 → 5.35.1 following this post but it didn’t work so I tried to revert the changes. Now I have an in the log error saying that:
{… “The database schema version and model versions do not match”,“schema_version”:“5.35.0”,“model_version”:“5.33.3”}
I would like to revert the changes to the 5.33.3 version, so I need to rebuild the database based on the 5.33.3 schema.
How can I do that ?

There are some tips in this thread on our community server that may help. We are also planning a bug fix for this.

1 Like

Thank you for your answer !
I posted a message there but ended finding a solution on my one after some diging.
For anyone interested, I had done a git pull, but had to change the ports because I am behind an apache reverse proxy, so I didn’t pay attention to the change of port 80 to 8080… but this was my error, setting it to 8080 fixed my configuration, I am well on 5.35.0 now.