Trouble during instalation, failed to reset read timeout from datasource

Hello, I’m having some trouble setting up a Mattermost server and I hope someone may be able to lend me a hand with it.

I get stuck in the part where i have to test the server to make sure everything works.

I get the error message →

I’m following the documentation referring to a ubuntu 20.04 LTS installation here and to be more specific I fail at the 9 step of the Mattermost server installation when I input the command → sudo -u mattermost ./bin/mattermost

I have followed the instruction and installed mysql and not the postgres variant.

I have seen that some people have similiar problems and they are generally due to a bad configuration of the config file in → /opt/mattermost/config/config.json

This is the configuration that I have right now:


I am also not sure, what to type under “SiteURL”: Is it http:// and then the private IP of my Server?

Anyone has any suggestions?

anyone has an solution / idea? :confused:

The URL that users will use to access Mattermost. Standard ports, such as 80 and 443, can be omitted, but non-standard ports are required. For example: This setting is required.

Mattermost may be hosted at a subpath. For example: A restart is required before the server will work correctly.

…is what the System Console is telling about that.

It’s basically the URL which will be “officially” used by anyone accessing your instance. So, it is not related to any private/internal URL, at all. It’s just the public address, visible to every user. Usually something like https://mattermost.domain.tld or something similar.