Unable to upload plugins


I am trying to upload a plugin onto mattermost. However, when i go into plugin management. The Upload Plugin part is greyed out. Any ideas?

I am an Sys admin user and have the latest server and client.

You need to enable PluginSettings.EnableUploads in your config.json file.


Compliments of the season

I am able to open the config.json file using * vi /opt/mattermost/config/config.json

However it opens in read only state, I am unable to edit it.

Do you have an idea why?

If you followed the installation instructions, then the file /opt/mattermost/config/config.json belongs to the useraccount mattermost and you’re probably trying to open the file with another account. To work around that, you can try to start the vi command with sudo or login to a root session using sudo -s first.

Hello all,

I have the same problem and I don’t know exactly where I should /can write this line in the “config.json”.

Who here has a more precise description of this?
What value do I have to set for this variable?
Best regards

Z. Matthias

Hi ZXRobotum,

the config.json file is divided into multiple sections, one of them is PluginSettings. In this section, there’s a key named EnableUploads which defaults to false.
Here’s what it looks like when you open it:

    "PluginSettings": {
        "Enable": true,
        "EnableUploads": false,

In orde rto enable the plugin uploads, you would have to change the value false for the key EnableUplodas to true with your favourite editor, then save the file and restart the Mattermost server.

Let me know if this helps or if you encounter any issues.


Thanks for the addition, @jmedlin , but the OP did not mention that they are running Mattermost inside a docker container, so I’m assuming the binary installation here.

BTW, @ZXRobotum , were you able to solve this?

Does anyone know how to fix this on a QNAP server? I’m not sure how to edit this file in that environment.

i also have same problem
i run on docker and check file size is ok and also ngnix is 100M but get same error!!!