Voice call not working in Mattermost version 7.4 Team Edition

For feature requests, please see: http://www.mattermost.org/feature-requests/.

For troubleshooting questions, please post in the following format:

I upgraded Mattermost Team Edition to the version 7.4 recently. I could see the the call feature available but it is not working. I could start the call but after 10 seconds it stops mentioning an error as in screenshot.

Steps to reproduce
Click on the call option in Mattermost version 7.4 Team edition

Expected behavior
Will receive the error as in the screenshot - Screenshot by Lightshot

Observed behavior
Tried changing the port from 8443 to 8445 to test and also rebooted the server after the upgrade to test any conflict of ports but none worked.

Hi Sandeep,

can you elaborate a bit on your setup? What deployment method did you use (binary, omnibus, docker, k8s, …)? Is there a firewall, loadbalancer or reverse proxy in front of your Mattermost server and if so, what does the Mattermost related configuration look like?
If you can establish a call but it drops after a few seconds this most likely is caused by either connection timeouts or improper NAT/tunneling configurations on devices in front of the Mattermost application server.