Gitlab Mattermost Calls Timing Out from Outside of Local Network

“Unable to connect to the voice call: timed out waiting for peer connection”

Mattermost calling from outside the network will display this error within seconds, and drop connection.

System Information
Install Type: Omnibus Gitlab Mattermost running in Docker
Gitlab Version: 16.4
Mattermost Version: 8.1.2

Hey all.
Our Mattermost installation is running in a Docker container (managed through Portainer) on a remote server. I recently upgraded the Gitlab installation, which went without issue as I followed the recommended upgrade path.
This added the Calls plugin, which was a nice surprise. When we call from within the network, everything works great, however the above issue happens when calling from outside of the local network, whether via computer or mobile app.
Our network is managed through an instance of NGINX. I read on another forum posting about compatibility issues with NGINX, however it’s running on the same server instance as the Gitlab/Mattermost container. Here is the port forwarding config from the container:

I had initially tried forwarding 8443 to 443, but that didn’t work either.
Here is the NGINX config for Mattermost:

server {
  listen 80;
  return 301 https://$host$request_uri;

server {
  listen 443 ssl http2;
  server_name [](;
    ssl_certificate /etc/letsencrypt/live/; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/; # managed by Certbot
  client_max_body_size 0;
  location / {
    proxy_cache off;
    http2_push_preload on;
    proxy_set_header Host $http_host;
    proxy_set_header X-Real-IP $remote_addr;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_set_header X-Forwarded-Proto $scheme;
    proxy_set_header X-Forwarded-Ssl on;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection $connection_upgrade;

I’ve read through this topic here and tried a few different things, but without any luck:

Can anyone give me any suggestions? All the traffic needs to be routed through NGINX as per our config, so there’s no way we can bypass that and go straight to Mattermost.
Any help would be appreciated!

I feel like an idiot.
We resolved the issue. There was an old configuration in the router that was forwarding 8443 to a dead IP address. Sorry for the waste of time!