Why mattermost-webapp required MySQL as well as Postgress databse?

I am setting up my developer machine (Windows-8) based on the steps provided on the
but when I run the command : make run-server
the postgress is not listening on the 5432 port.
Can I remove postgress specific lines from the docker-compose.yaml file and from other respective files?
Why do we need mysql as well as postgress database ?

Help me to setup my local machine enviromnet to make the webapp up.
Following the provided steps on the given link is not working.
Is there any change in the steps to follow ?

@rajkirpalsih, this is just an artifact of our development environment, in which we run unit tests that execute on both MYSQL and Postgres. You are free to modify the docker-compose.yml files accordingly. The webapp should start up so long as your server is running succesfully.

1 Like

Hi Jesse,
I have checkout the server from the github. I am following the steps given on the below link:
when I execute : make run-server
command I get the screen I have attached with this

How can I know server is running or not ?
I tried to access : crul http://localhost:8065/v4/system/ping
but it give connection refused.

Is there any other way to bring the server up in windows machine?

Hi @rajkirpalsih!

I don’t use Windows myself, but I’ve heard nothing but pain from developers who try to use PowerShell directly. I’d recommend trying the WSL setup and seeing if that works better.