6.0 Important Upgrade Notes

Glad that it’s resolved for you @asym.

@RaSt What is your MariaDB version?

@isacikgoz the MariaDB-Version is 10.1.48

@RaSt Can you update your MariaDB version to a newer one e.g. 10.5+? I think it should work this out.

ive updated MariaDB and it works… Thanks

I´ll update the MariaDB and try the update again.

For Ubuntu LTS users: An update to MariaDB 10.3.31 (which comes with Ubuntu LTS 20.04) solves the problem, too

I´ve updated the MariaDB to 10.5 and the Mattermost-Update afterwards to 6.0.3 worked.
Thank you very much.

Can confirm, if you upgrade MariaDB (we do it to version 10.7) is working fine!

I’ve just upgrade to GitLab 14.6 which comes with Mattermost 6.1 - update went through without any error message, but Mattermost service is not available. Looking into the log, I’m seeing these a lot:

{"timestamp":"2021-12-22 15:54:04.626 +01:00","level":"fatal","msg":"Failed to alter column type. It is likely you have invalid JSON values in the column. Please fix the values manually and run the migration again.","caller":"sqlstore/store.go:906","error":"pq: default for column \"timezone\" cannot be cast automatically to type jsonb","tableName":"Users","columnName":"Timezone"}

I believe that the GitLab installation uses PostgreSQL (version 12.7 in my case) and I have no idea what I need to be doing to fix this.

EDIT: found the solution in PostgreSQL error when migrating from 5.39.0 to 6.0.0


I encountered some issues when upgrading from 5.39.0 to 6.0.0 through the helm charts (chart 5.5.1 to chart 6.0.0).

I am running this on postgres 12.7 and when the update pod tries to start I get the following error :

"level":"fatal","msg":"Failed to alter column type.","caller":"sqlstore/store.go:860","error":"pq: must be owner of table posts"

When I upgraded my helm from 5.4.0 to 5.5.1 everything worked without a problem but this version update fails continously.

I created an issue for this but no replies yet.

Any help would be greatly appreciated !