Allow non google dns resolution i windows desktop client

Please add option to use or not google dns in server name resolution.
I’ve setup reverse proxy and static host mappings on my internal dns to be able to connect to mattermost from inside my network.
Google dns is ommiting my internal dns.

Hi and welcome to the Mattermost forums!

I’m not sure I can follow you on that topic - can you please explain where you saw Google DNS to be involved?

I think its involved in server name resolution in windows Destkop App.
My configuration rewrites dns to internal ip is internal address of reverse proxy with ssl support.
Users in my internal network can reach mattermost server this way.
It’s better solution than using hairpin NAT.

Web App works fine, but I think that desktop application involves for names resolution so its not rewrited by my dns.

My workaround is to use ip address instead of domain address, but i loose flexibility in this way.
I need 2 seperate server names in Desktop client conf - One used when user is inside company and second one when he is outside.

I’m almost certain that the desktop application does not default to using the Google nameservers, not sure why it should do that. The desktop app is also being used in air-gapped environments for customers and one of my mattermost servers f.ex. is only available via hosts file entry or DNS override and I can connect to it just fine with the desktop app, so there must be something different/wrong on your system.

Since you mentioned hairpin NAT: Do you have a firewall in front of the client where you’re running your desktop app and if so, can you see the DNS requests to google servers in the packet traces when you start the app?

I found something like this in
c:\users~\AppData\roaming\Mattermost\Network\Network persistent state


it looks like dns over https.
Its completely invisible to packet tracers.
It looks like ssl over 443
Desktop client version 5.1.1

I think i found whats causing this strange behavior.
Mattermost Desktop is cycling through all dns servers set on my system, when it hits my internal dns server everything is fine because i rewrited to, but when it hits or i cannot reach cause its pointing my external ip address.
Please set dekstop client to rely on system settings.