Attempted to update and expand VDISK now cant boot mattermost

I am currently running mattermost on a turnkey linux VM on my unraid server. I’ve been needing to update mattermost for sometime and had been putting it off for sometime. Upon attempting to update I ran into the first problem. I did not have enough space and the update failed. I’ve tried expanding the Vdisk (/dev/vda1) but I cant seem to find the proper way to expand vda properly. upon executing cfdisk i can see the size of vda1 (72G) and free space of 420G. If i attempt to resize it says the max size is that 72G. Upon executing df -h i can see that vda1 is 100% used.

Also now for some reason i cannot start the mattermost server, i’m assuming this is because of the disk being out of space but not completely sure. if i execute sudo systemctl start mattermost i get: Job for mattermost.service failed because the control process exited with error:
Job for mattermost.service failed because the control process exited with error code.
See “systemctl status mattermost.service” and “journalctl -xe” for details

upon running journalctl -xe the error appears to be: Error: failed to load configuration: failed to create store: unable to load.

I’m really not sure where to go from here. My hope is that i simply need to figure out the proper way to expand the vda1 and that this will resolve the issues but I am unsure at this point.

Just checking to see if anyone had any thoughts here. I have 3 years of messages in mattermost and its not ideal having it down this long.

Not sure what else to do here but just move to slack and be done with it… As i cant get the mattermost server to boot im unsure how i’ll ever recover the message history.

Hi @anatwick,

Thanks for reaching out and sorry to hear you’re encountering issues. These types of problems can be frustrating, but I’m confident we can work through them together!

Just to confirm, it seems like the primary issue is expanding your VDISK (/dev/vda1). Given that your vda1 shows as being 100% utilized, that could definitely be why your Mattermost server isn’t starting up—it likely doesn’t have enough space to handle its operations.

There are a few steps that we can try to resolve your issue:

  1. Expanding the Disk: You mentioned that you’ve tried expanding the Vdisk, but it shows a maximum size of 72G. I recommend double-checking the methods you’ve used to expand, and making sure you followed documentation or expert advice rigorously.

  2. Checking for Disk Errors: It’s also worth running a fsck on your disk to look for and correct any potential errors. This can be done by entering the command fsck /dev/vda1 in your terminal.

  3. Free Up Some Space: As a quick fix for the out of space issue, try to clear some disk space. This could include removing old backups, cache, or even applications that you might not use.

Regarding the error about failing to load configuration, it might be a separate issue, or it could be tied into the fact that your server is out of space. Your hunch about figuring out the proper way to expand the vda1 could indeed resolve the issues.

Remember to always create a backup before making changes like these to your systems to avoid any loss of data!

If you need more detailed instructions or if these steps don’t solve the issue, don’t hesitate to get back in touch. I’m here to assist in any way I can.

~Mattermost AI Assistant :robot:

[Disclaimer: This was an AI assisted response powered by Mattermost AI. Were any of the above suggestions inaccurate? Let us know by replying to this comment!]