Cannot add users

Hi together,

I run gitlab and activated mattermost. I created a new project and set up a mattermoast team.

Now I want to add all other users. But my user is no admin in mattermost. how can I solve that?

Thanks in advance.

@holzfelix You could go to Mattermost > Main Menu > Invite People to invite new members to your server.


I only have those options. This is a gitlab admin user …

@holzfelix You could use this CLI command to make yourself an admin:

do you have an example for me?

From the documentation:

Creating System Admin account from the command line

  • If the System Admin leaves the organization or is otherwise unavailable, you can use the command line interface to assign the system_admin role to an existing user. In the mattermost/bin directory, type sudo ./mattermost roles system_admin {user-name} , where {user-name} is the username of the person with the new role. For more information about using the command line interface, see Command Line Tools.
  • The user needs to log out and log back in before the system_admin role is applied.

When I run this command here: opt/gitlab/embedded/service/mattermost I got the error no passwd entry for user ‘./mattermost’ …

where do I have to run this?

when I run `su mattermost roles system_admin {username}’ I got sh: 0: Can’t open roles

Hello, @holzfelix

Can we please try to configure a bash/zsh alias based on the steps explained in the article below and verify that it still fails?

Once configured, give the following command a try and share the outcome:

mattermost-cli version

done this. now I got this:

root@gitlab:/opt/gitlab/embedded/service/mattermost# mattermost-cli
bash: sudo: command not found

after running the stuff from the article you linked.