Making user System Admin in team edition (kind of)

OK, the ‘kind of’ is because for some reason the version shows as Enterprise even though I set edition to the team. From looking at this forum it seems this should not matter (i.e. without a licence I simply don’t have enterprise features.

However, I can’t work out how to set a user to System Admin, all the docs talk about using the System Console (which is an enterprise feature).

So how do I make a user a System Admin, In Manage Members all I can do is make a member a Team Admin.

OK, seems there is a CLI. I tried to use it but got an error, any ideas?

$ docker exec -it mattermost-docker_app_1 mattermost roles system_admin stfl
{"level":"error","ts":1587845893.3920557,"caller":"app/server.go:787","msg":"Elasticsearch.start: Elasticsearch is already stopped, "}
2020/04/25 21:18:13 [ERR] yamux: Failed to write header: write unix @->/tmp/plugin635168771: use of closed network connection


Hello, @funkytwig

May I know if you have tried the following command on your server based on the Creating System Admin account from the command line article?

sudo -u mattermost bin/mattermost roles system_admin {user-name}

Let me know how it goes.

I am using docker and when I do this command it runs the command as the mattermost user so that is what I am doing. The docker-compose ( does not have sudo as it is not realy needed. So I am running the the eqivelent of comand. Interestingly when I do
docker exec -it mattermost-docker_app_1 /mattermost/bin/mattermost version
I get
{"level":"error","ts":1588197233.7719185,"caller":"app/server.go:787","msg":"Elasticsearch.start: Elasticsearch is already stopped, "} Version: 5.21.0 Build Number: 5.21.0 Build Date: Fri Mar 13 12:16:12 UTC 2020 Build Hash: f51c4f18f007494c3858fd029bf76819ff12ff1e Build Enterprise Ready: true DB Version: 5.21.0
So the mattermost command seems to be running fine.

@funkytwig, the system console is accessible to both the team and enterprise editions. It’s simply referring to the configuration screens at /admin_console on your instance. It’s only accessible to existing system administrators. You can promote users to system administrators from /admin_console/user_management/users.

1 Like