Cannot create new card

When the +New button is clicked on in for a board, nothing happens

Steps to reproduce
Version 7.2.0, desktop version on ubuntu 22.04. mattermost cloud server

  1. open an existing board
  2. click on +new - nothing happens. No error, no screenflash, nothing

I can open and edit an existing card

Hi jmoore and welcome to the Mattermost forums!

Just to verify since you said “desktop version” and “mattermost cloud server”: You’re accessing Mattermost Boards as part of the Mattermost Cloud offering using a desktop client installed on your Ubuntu system, right?

If so, what client version are you running and how many cards do you have already?
Can you create a new board and are you able to create a new card there, then?
Can you reproduce the problem using the webapp in your browser?


Yes @agriesser I am using the Matermost Cloud offering

Desktop version 7.2.0 installed on Ubuntu.

We have about 50 cards. I can reproduce by creating a new board clicking the +New button. But… the New dropdown in the upper right → Empty Card does work!

I can reproduce everything using the webapp in browser as well.


Interesting - I just tried to create 50 cards in my cloud account, works (thought that there might have been a limit or so, but if there is one, it’s not 50).

Does any of the other “New” options work for you? You can create cards in every view (gallery view, kanban view, list view, …)?

Interesting. I CAN create new cards in every view except the Board view (kanban style view). The list view, calendar view, etc allows me to click the +New and a new card pops up. Only in the board view does it now work, unless I select New->Empty Card from the New dropdown.

That’s very interesting. I know that a new version has been released recently, can you maybe try to clear your browser caches or local data of your browser or try with a different browser, just to see if that changes anything?

So to get you right, the popup window where you can fill the card does not appear, right? It’s not that the popup window shows up, you enter data and the card is not being saved when you leave the dialog, correct?

Correct, the popup does not appear. I tried a new incognito chrome window and had the same results. I tried in firefox with same results as well. :frowning:

OK, thanks for confirming - let me see if I can find someone who might be able to assist you with that.

1 Like

Hi again,

this is a known issue. A fix for that will be rolled out next Thursday (August 25th). Sorry for the inconvenience, but in the meantime, please use one of the workarounds we found out here in this ticket or described in the GitHub issue.