Cannot end a call

A call with a teammate seemingly cannot be ended.

Steps to reproduce
Using Cloud Starter plan. I’m using the web version, teammate was using windows app.

Expected behavior
Being able to start a new call.

Observed behavior
We were on a call. We finished the call (don’t recall whether by closing the tab or through the UI). App still shows us as being on call, but doesn’t show the usual interface when we are. There is simply the call icon next to teammate’s name and the “start call” button is now a (disabled) “join call” button.

Tried restarting PC and logging out. Tried disabling and removing the Calls plugin. On re-install it is still stuck on the call.

What else could I try? Thanks.

Do you see JS console log errors?

  • Chrome Browser: Press Command+Option+J (Mac) or Control+Shift+J (Windows, Linux, ChromeOS)
  • Firefox: Ctrl + Shift + J (or Cmd + Shift + J on a Mac).
  • Safari: Enable Developer Menu in Safari → Preferences → Advanced → “Show Develop Menu in Menu Bar”

Then Develop → Show Javascript Console

Usually you can right click on the console and select the “Save to file” option.

Thanks for reaching out. Yup:

The log file is too large to upload. Let me know if you want the details of a specific error.

Thank you, would you be open to sharing this issue either in our community server’s Calls channel or at Issues · mattermost/mattermost-plugin-calls · GitHub? One of our Calls team devs can help troubleshoot this.

Done. Thanks!

Running /call end fixes the issue.