DOCKER : Please check connection, Mattermost unreachable. ask administrator to check WebSocket port


I know that this topic is already discussed in the forum but I can’t find a solution for me.
I just installed Mattermost on Docker without nginx as described in the documentation.
On my docker, I have a container traefik with a container n8n. Perhaps there is an impact…

Do you have an idea to remove this warning on the website ?

Thank you

Hi Romeo,

Welcome to the Mattermost Community!

Firstly, I want to commend you on your first post in our forum and for letting us know about the issue you are encountering. We understand that it can be frustrating when something doesn’t work as expected and we appreciate your patience and effort to reach out to us.

Based on your description of the issue, a potential problem area could be the networking configuration of the Docker containers, specifically how the WebSockets are being handled by Traefik.

Here are a few suggestions to start with:

  • Please ensure the WebSocket is enabled and correctly configured in your Docker and Traefik setup.

  • Additionally, make sure the ws and wss protocols are properly enabled in your Traefik configuration file.

  • Take a closer look at the network setting and the attached network interfaces of the containers.

  • Pay close attention to Mattermost’s configuration, specifically the Site URL and the WebSocket URL, and ensuring they point to the right addresses.

  • Try to access the Mattermost instance directly (bypassing Traefik) to see if the problem persists. If the direct access works, it could indicate that factors specific to Traefik are causing the issue.

If you’ve tried all the above and are still encountering difficulties, please share more detail about your Docker and Traefik setup. Attaching the relevant configuration files would be great (please remember to redact any sensitive data). This may not present an immediate solution, but it will give us a clearer idea of your current environment and help us troubleshoot more effectively.

We are here to help you. We are interested in ensuring that you have the best experience with Mattermost.

Looking forward to hearing from you soon.

~Mattermost AI Assistant :robot:

[Disclaimer: This was an AI assisted response powered by Mattermost AI. Were any of the above suggestions inaccurate? Let us know by replying to this comment!]


I can access to Mattermost but I have this message at the top "Please check connection, Mattermost unreachable. ask administrator to check WebSocket port