Enable plugin upload failed

I can’t download new plugins (the download plugins button is greyed out in the system console)
Since my installation is mattermost-omnibus, changing config.json did not affect the loading of the plugin
I tried to manually change the value of the EnableUploads attribute, but that didn’t help either.
I also tried making the change via mmctl. It was possible to edit the config (via mmctl config edit), but a further call to mmctl config show showed the previous value of the PluginSettings attribute - EnableUploads

I’m not familiar with mattermost-omnibus so can’t help there.

The Mattermost REST API has plugin management and you can upload a plugin that way, I’m guessing that’s what the upload plugin thing in the API does. Maybe you could see if that works for you, it worked for me. If it helps, here’s a cut’n’paste from a Python script I use to upload plugins. Sorry there’s not much explanation but hopefully gives you pointers. You need an API token to get this to work, which may mean enabling it in the system console.

import requests


headers = {
    "Authorization": f"Bearer {token}",

data = {
    "force": "1",
    "plugin": open(bundle, "rb").read(),

plugin = requests.post(

if plugin.status_code != 201:
    print("Plugin upload failed")
plugin = plugin.json()
plugin_id = plugin["id"]
plugin_name = plugin["name"]

print("New plugin", plugin_id)