[Solved] Mattermost Omnibus - Can't change Config - Security Reasons

mmctl config set PluginSettings.EnableUploads true
Error: : Changing PluginSettings.EnableUploads is not allowed due to security reasons.

My set-up:
Mattermost omnibus edition on a remote Ubuntu 20.04 server I have SSH’d into. The config is stored in the database (there is no config.json) which I believe is the default for this distribution.

Before running the above code I also run mmctl auth login http://localhost:8065, enter my credentials, and get ‘credentials … stored’.

Furthermore, I can edit the setting via mmctl config edit and save & exit the file, and it says something like ‘config changed successfully’, but upon running mmctl config show immediately afterwards (or mmctl config edit again), it is evident that the change has not been stored.

I get the same result whether I run mmctl or /bin/mmctl.

Your help would be much appreciated.

If you had just read the instructions for setting up a Mattermost omnibus server, you would have realised that the instructions for enabling plugins are handled by the yaml mmomni.yml file in /etc/mattermost folder on the server. Instructions are below:

Thanks so much for following up with the solution/clarification, fffjjjggg! And I’m glad to hear you were able to get it figured out. Happy Mattermosting out there!