Mmctl config changes won't save

mmctl config edit changes won’t take whether I edit the local config or the server config. I was initially trying to edit the SSL parameters, but realized the new omnibus install I just did was using NGINX for reverse proxy. So eventually I figured that part out. The catch here, and I don’t know if this is a potential cause, the first time I ran mmctl config edit I was able to adjust the filepaths for the SSL certs. No change since has stuck.

Currently, I’m trying to enable plugin uploads. I manually edited the mmomni.yml per the documentation, which did save. Restarted the server. Still can’t upload plugins. I would rather not do the CLI installation. Any ideas why mmctl config edit changes aren’t being saved? I wouldn’t think that changing the plugin upload value from false to true would be an invalid change - and thus be ignored.


What use are you doing this as, and what’s the output of an ‘ls -lZ’ on the config file?

Thanks John

Doing w/ sudo if I’m understanding the first part of the question. Unless I’m reading the docs wrong the config file has no purpose as its overridden by the env variables set w/ mmctl.

That being said, if you are talking about the /opt/mattermost/ config files this is the output for config.defaults.json:

-rw------- 1 mattermost mattermost ? 19389 Jan 19 16:48 config.defaults.json

and this is the output for the mmomni/ansible/playbooks/mattermost.conf:

-rw-r--r-- 1 mattermost mattermost ? 3732 Jan 22 14:01 mattermost.conf

I am not a huge expert here! I do know you can mmctl config show and dump the current running config. So you could redirect the output to a text file to replace the config.json There’s a --json flag you could use for that.

Well, I still didn’t figure the deal exactly, other than there is some permission overriding the ability to edit that.

That being said, you can get around this by downloading the plugin package into the /opt/mattermost/plugins folder, it will then show up in the system console > plugins.

I wasted a lot of brain cells trying to do this the right way…and the “security” restrictions of mmctl were overridden by simply putting the package in that folder? wtf mattermost devs (looking at the omnibus specifically). Also, acknowledge there is a greater than zero chance it was user error somehow during setup…did that when I was pretty tired.

Hello, guys.
I have a same problem.
I neeg enable plugin uploads.
I change mmomni.yml but i can’t change config.json.
I use mmctl comand sudo mmctl --local config edit and save.
But enable pluginuploads is still false.
Please, help me)))