Failed to open the zip file when migrating from cloud to self-hosted


We are using the Mattermost Cloud and would like to migrate it to self-hosted instance. We tried to do the migration according to the docs, but got errors when executing the mmctl import process command.

Steps to reproduce

  • Create and download a full export of the cloud server
  • Install the latest stable version (7.10.3) on Ubuntu
  • Upload the export to the self-hosted server
  • Import the export into the self-hosted server

Expected behavior

Import successfully

Observed behavior

  • We got the following error when executing the mmctl import process command: Data: "map[error:Error during job execution. — ImportProcessWorker: Unable to process import: failed to open file., zip: not a valid zip file import_file:"
  • It seems like the size of downloaded export is much smaller (891MB) than the size we have used at the Cloud (1.7GB).
  • We got the following error when extracting the downloaded export under macOS: Archive: End-of-central-directory signature not found. Either this file is not a zipfile, or it constitutes one disk of a multi-part archive. In the latter case the central directory and zipfile comment will be found on the last disk(s) of this archive.
  • The export created with the --no-attachments argument can be imported into the self-hosted server successfully.

Hi Sol and welcome to the Matetrmost forums!

the exported zip is definitely corrupt which is why you cannot import it. Not sure if there’s anything you can do about that except for trying again, but you should get in touch with the Cloud support so they can help you with the export if your generated zip continues to be broken.

Thank you @agriesser!

We have contacted the support but they said the free Cloud user is not eligible for support.

Is there any option for me to get help from the Cloud support?

I’m not sure what the options are here, but I think that since the free cloud options are being terminated there should be a safe option for people to get their data from the cloud before it is being turned off.
@amy.blais could you help with that maybe?

1 Like

I’ll check with our team about this. Stay tuned!

1 Like

Do you have a link to the Support ticket that you opened previously? Do you have details on your email address and installation ID? You can send me the details via a Private Message here.

@amy.blais @agriesser

The date of cloud free depreciation is close, but we have got another problem of export:

ID: st9649igktb19ee6qqgwjoayjc
Status: error
Created: 2023-07-20 00:34:46 +0800 CST
Started: 2023-07-20 04:46:15 +0800 CST
Data: map[channels_exported:10 direct_channels_exported:46 direct_posts_exported:38750 error:Error during job execution. — exportFileAttachment: Failed to copy file during export., err=The specified key does not exist. include_attachments:true posts_exported:8566 teams_exported:1 users_exported:18]

I have tried several times but in vain…

This is related to an incident that we’re currently investigating. Feel free to sign up for status updates via .

1 Like

Is the issue resolved for you?

Yes, we have successfully migrated our instance from cloud to a self-hosted server! Apologies for the delayed response.

1 Like