Importing trello board problems - am I missing something?

despite following the instructions from the docs (Import your data — Mattermost documentation) I’m unable to convert exported trello .json file to .boardarchive file.

Steps to reproduce
mattermost 6.6.1 deployed on debian based crunchbang++ distro in hyper-v, win 10

following the aforementioned doc (points 4 and 5) after changing direrctory to focalboard/webapp and running npm install nothing happens, output is up to date, audited 1 package

There is no focalboard/import/trello directory though (point 6) which I assume should be created automatically. Trying to create the directory manually obviously doesn’t work, output of importTrello.ts command is Error: Cannot find module './importTrello.ts'

Expected behavior
I’d expect point 5 to create focalboard/import/trello directory and install importTrello.ts module

Observed behavior
Pretty much described in Steps to reproduce section

Additional comments
Mattermost installation works fine, there were no problems during deployment.

Whole procedure is to convert trello .json to .boardarchive that could be imported into cloud-based Mattermost instance (that in theory lets me import .boardarchive file but provides no tools for conversion).

I’d be grateful for tips pointing me in the right direction.

I am also having problems with this. In my case, I was able to create the .boardarchive file from the trello JSON, but when I try to import it the console shows

ERROR importing archive: [object Promise]

the file itself looks fine to me when I open it in VS code, looks organized, etc. I tried exporting a board from mattermost, to see if I can find a difference, but when I try to open this mattermost export VS code says the file has an unknown text coding or is binary (? sorry, message is in german, not sure about this).

@bc_is_too_short to address your problem, you have to clone the git repo and npm install the webapp on your computer, the import/trello folder is there from the beginning. you have to have a github SSH key set though, I was having problems with this before but after adding the SSH key to github all was good. I used the latest node and npm


this is what worked for me - maybe you can get yours working with these instructions too:

# Install the necessary tools and dependencies
apt-get install nodejs npm git
npm update
npm install cross-env

# Download the focalboard source and install all relevant dependencies
cd /usr/src
git clone focalboard
cd focalboard/import
npm install
cd webapp
npm install

# convert the exported trello.json file to an archive.boardarchive file
cd trello
npx ts-node importTrello.ts -i /path/to/trello.json -o /path/to/archive.boardarchive

The output of the last command should then look similar to this:

Board: test123
Found 0 card(s).
Exported to archive.boardarchive