Importing boards from Jira - nothing happens

We’re trying to import some Jira boards into Mattermost Boards and have followed this official guide.
I’m only testing with an import of about 10 boards from Jira.
When we try to import the converted jira .xml file in the Mattermost Board, nothing happens.
I know the import works as i’ve exported another mattermost board (a .boardarchive file) and imported into Boards and it worked fine. It’s just the converted jira .xml not working.
Has anyone else had this issue? Not sure what else i can share to shed more light into this bug.

Hi @aivwelw and welcome to the Mattermost forums!

If it’s failing silently without giving you any error message, there might be something wrong with the generated boardarchive file. Do you have a test board in Jira which is populated with demo data only where you could share the generated xml and boardarchive files here so we can have a deeper look?

Hi @agriesser , thank you for getting back to me!

i just noticed now that there was a “TypeError” when converting the .xml.
This was the output:

input: jira-mattermost.xml
output: archive.boardarchive
Reading jira-mattermost.xml
Read 3 KB

    const priorityProperty = buildCardPropertyFromValues('Priority', => o.priority?._))
TypeError: is not a function
    at convert (/focalboard/import/jira/jiraImporter.ts:96:76)
    at (/focalboard/import/jira/jiraImporter.ts:74:30)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)

Maybe this is the issue? I do not know node.js so trying to find more info on the error. if you can enlighten me or point me in the right direction? Thank you!

Thanks, @wuwinson can you chime in here on this one?

@aivwelw I filed MM-51319 for the team to investigate. My links are getting flagged as spam so unable to link the ticket here unfortunately. Can you provide some system details to help the team?

Edition and Platform

  • Edition: Personal Desktop / Personal Server / Mattermost Boards (plugin)
  • Boards Version: [e.g. v0.15.0]
  • Browser and OS: [e.g. Chrome on Mac, Edge on Windows]


Hi @wuwinson thanks for checking this.

  • Edition: Personal Desktop / Personal Server / Mattermost Boards (plugin):
    macOS 13.2.1 / ubuntu-jammy-22.04-amd64-server / Jira plugin
  • Boards Version: [e.g. v0.15.0]
    im not sure where to find board version but i’m using the latest (i think) Mattermost version : 7.1.5
  • Browser and OS: [e.g. Chrome on Mac, Edge on Windows]
    Chrome on macOS

Thanks @aivwelw!

For the Edition - Do you know which of the following editions you’re on?

For the Boards version - you can find that on the top right corner within Boards:


Oh! it’s v7.1.0. Should it be higher? Looking to see how to update this to the latest. Odd since it just spun this server and mattermost install up just recently.

What deployment method did you use? Docker? If so, the docker environment file pointed to the 7.1 release some time ago and has recently been changed to the latest ESR release (7.8), so if you’re on docker, change the value of MATTERMOST_IMAGE_TAG in your .env file from whatever it is right now, to 7.8.1 and restart the containers, the application will upgrade itself then (including a new version of the boards plugin).

ah yes, makes sense. yes, it was a docker deployment.
i’ll check to see how i can update this and get the new version to the Boards.

Hi @agriesser , I tried what you suggested and changed the value to the most recent Boards plugin (7.8.3) and restarted the containers but still on 7.1. I tried to upload the .tar.gz file following this guide (Installing the latest plugin) but get an error of “Received invalid response from the server.” when i try to upload. I checked the logs and the cause might be because the max file size is too low so I changed that in the config.json and nginx.conf according to this guide: (, and changed those max file sizes to 200mb but still getting the same error. Any ideas?

If your container is able to access the internet, you can upgrade to the latest boards plugin directly from the marketplace:


The latest focalboard plugin is only about 50MB in size. I assume you did restart/reload nginx and mattermost after you made the changes with regards to the max upload file size, right? You could start with checking the nginx error log to see if it contains additional information for the error.