Intermittent "The Server is Not Reachable" for some users on mobile

Hey there,

We’ve had Mattermost Team Edition running on a Synology NAS in a Docker container for a couple of months now. We connect via desktop and mobile, and access via reverse proxy and LetsEncrypt cert.

Through that time, we’ve had one staff member in particular who has been having a lot of issues (many times a day, basically unusable) on the mobile app, with “The Server is Not Reachable” error message, and red (i) icon for messages that aren’t sending. We have one other staff member who has a similar problem, but far less frequently. Two other staff members have no problems.

We are running v8.1.2 MM, and the most current mobile apps (all android). This has been happening since when we first launched MM (which was a v7).

It doesn’t seem like the staff members that are having problems have any VPN or unusual DNS settings on their mobile devices. Both staff members who are having some issues are using Samsung phones. The staff members who aren’t having issues are using OnePlus & Essential devices.

In terms of resolving the issue temporarily, sometimes flipping airplane mode on and off helps.

I’ve tried searching out solutions, as well as other people having similar issues, and didn’t get anywhere unfortunately. Any thoughts or help would be much appreciated. Thanks!

Hi Dustin,

Welcome to the Mattermost community forums, and we’re sorry to her about the frequent connection issues.

Let’s try to troubleshoot this problem together. Here are a few suggestions:

  1. Check network connectivity: Ensure that the affected staff members have a stable internet connection on their mobile devices. You can ask them to try accessing other websites or applications to see if they encounter any network-related issues.
  2. Update the Mattermost server: Make sure your Mattermost server is up to date. Check if there are any available updates for the server, and if so, consider upgrading to the latest version. This could potentially resolve any known issues related to mobile connectivity.
  3. Verify mobile app configuration: Double-check the configuration settings on the mobile app for the affected staff members. Ensure that the server URL is correct, and that there are no typos or missing characters. Also, confirm that the app is set to use the appropriate port and protocol (HTTP or HTTPS) for your setup.
  4. Restart the Mattermost server: Try restarting the Mattermost server running on your Synology NAS. Sometimes, a simple server restart can resolve temporary connectivity issues.
  5. Check firewall or network restrictions: Verify that there are no firewall rules or network restrictions blocking the mobile app’s access to the Mattermost server. Check if any network settings or firewall configurations have changed recently.
  6. Review server logs: Check the Mattermost server logs to see if there are any error messages or warnings related to the mobile connectivity issues. The logs might provide more insight into the root cause of the problem.

If none of these suggestions resolve the issue, please provide more details about your setup, such as the reverse proxy configuration, any recent changes to your environment, or any other relevant information. This will help us in further diagnosing the problem and finding a solution.

Best regards,
~Matterbot 2.0 :robot:

[Disclaimer: This is a beta AI assisted response powered by ChatGPT. Were any of the above suggestions inaccurate? Let us know by replying to this comment!]

PS: I (John) will be sure to personally share this feedback with the rest of the team as well in hopes that we can perhaps signal for more specific human advice in this area. Thank you in advance for your continued patience!

  1. Affected staff members have no issues with connectivity with any other apps or websites.

  2. Server has been updated several times in the past couple of months and is on the latest version as of 2 days ago.

  3. URL is correct. The connection issue is intermittent.

  4. Server has been restarted multiple times over the past few months with no change.

  5. No firewall issues on the server. Several other staff members have no connectivity issues.

  6. Can you point me to which logs I should be looking at, and where to find them?

Synology NAS 920+ running on Docker instance
Reverse proxy setup w/ LetsEncrypt
Set up according to this website

Happy to provide any other information that may be needed.

This was solved, though I’m not 100% sure how. I believe it may have had something to do with the DNS servers listed in the NAS or the router. They were slightly different (using Google/Cloudflare), and making them match seems to have resolved the intermittent connectivity issue.

We have also submitted a fix for this issue which is queued for an upcoming mobile app release Fix can not reconnect websocket after turn off then turn on wifi. Thi… by namanh-asher · Pull Request #7552 · mattermost/mattermost-mobile · GitHub.