iOS clients stopped working after client update to 2.12.0


We have self deployed (Ubuntu) Mattermost server 9.4.1. Today users with iPhones received Mattermost client update to 2.12.0 and are not able to communicate. When they send message the exclamation mark appears instantly. Android, MacOS Clients work ok. They also see messages from others but are not able to respond. The only iPhone that works is the one with auto updates off - the client did not update itself overnight.

15 users. Http connectivity. Ubuntu. When I log out from server a cant log in again. I cannnot get past the login screen. The button says “Connected” and nothing happens. There are no errors in logs on the server side.

does anyone have the same problem?

update: got some logs from client devices and I see errors like these:

2024/01/18 08:11:52:808 DEBUG error on fetchMyTeams Received invalid response from the server.; URLSessionTask failed with error: The resource could not be loaded because the App Transport Security policy requires the use of a secure connection.

Do we have to switch https connection instead of http ?



Pawel - I looked into this a bit for you. iOS 9 began to mandate TLS via Application Transport Security NSAppTransportSecurity | Apple Developer Documentation We may have overridden that for a while, but TLS is pretty ubiquitous now. You can use Let’s Encrypt to generate certificates for free

You can refer to our changelogs when an update changes what you’re used to:

1 Like

Thank you for your help John. We’ve switched to TLS using Let’s Encrypt and the problem is solved.

Honestly, I’ve looked through all the changelogs and I don’t see any mention of having to switch to TLS because the client will not work anymore with http connection.

Obviously I understand, that switching to TLS will be mandatory in future and today was the day this coming :slight_smile:

Problem solved. Thank you.

Here are a couple of reasons why your iPhone might not be updating automatically overnight, even if it’s plugged in and connected to Wi-Fi. Here are some things you can try to fix it:-
1. Check Automatic Update Settings:- Make sure both “Download iOS Updates” and “Install iOS Updates” are enabled in Settings > General > Software Update > Automatic Updates.
2. Restart Your iPhone:- A simple restart can sometimes clear up software glitches. Restart your iPhone, then check for updates again.
3. Delete and Retry the Update Download:- If the update download seems stuck, try deleting it and downloading it again. Go to Settings > General > [Device name] Storage, find the update in the list, and tap “Delete Update”. Then go back to Software Update and try downloading again.
4. Check Storage Space:- Your iPhone might not have enough space to download the update. Try deleting unused apps or files to free up space.
5. Check Wi-Fi Connection:- Make sure your iPhone is connected to a strong and stable Wi-Fi network.
More details instruction below.